NodeJs项目报错 Unsupported protocol version

142次阅读
没有评论

使用 nodeJs 使用 socket.io 组键构建了一个服务端,使用的版本 4.5.1

{
  "dependencies": {
    "axios": "^0.27.2",
    "connect-multiparty": "^2.2.0",
    "express": "^4.18.1",
    "socket.io": "^4.5.1",
    "validator": "^13.7.0"
  }
}

然后用 vue 项目构建了一个客户端,去请求服务端,请求结果总是报 {“code”:5,”message”:”Unsupported protocol version”}

原因是 socket.io 客户端与服务的的版本不一致导致的。

看来一下客户端的 package.json 的 “socket.io-client” 版本为 “^2.2.0”

此时需要升级客户端的版本

# 更新 socket.io-client 到 4.5.1 版本
npm install socket.io-client@4.5.1   

OVER!

正文完
有偿技术支持加微信
post-qrcode
 
评论(没有评论)
验证码